summary refs log tree commit diff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-17 15:39:12 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 12:30:39 +0200
commitb90dc0641033db1273a392faea61f82e9aeb1e85 (patch)
tree0d4a5462e8c84d3e9a6a4aca7493a2e145c2a7da
parent6eaa449d63afa217c590f0520bea043ab1f6e107 (diff)
downloadguix-b90dc0641033db1273a392faea61f82e9aeb1e85.tar.gz
gnu: ipfs-go-ipfs-cmdkit (DRAFT)
-rw-r--r--gnu/packages/ipfs.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index 4e9661e09b..fbe572485f 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -20,9 +20,34 @@
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix git-download)
+  #:use-module (guix gx-download)
   #:use-module (guix build-system go)
   #:use-module (gnu packages golang))
 
+(define-public ipfs-go-ipfs-cmdkit
+  (let ((ipfs-hash "QmSP88ryZkHSRn1fnngAaV2Vcn63WUJzAavnRM9CVdU1Ky"))
+    (package
+      (name "ipfs-go-ipfs-cmdkit")
+      (version (gx-version "1.1.3" "1" ipfs-hash))
+      (source
+       (origin
+         (method gx-fetch)
+         (uri (gx-reference (hash ipfs-hash)))
+         (file-name (gx-file-name name version))
+         (sha256
+          (base32
+           "0qk6fshgdmhp8dip2ksm13j6nywi41m9mn0czkvmw6b697z85l2r"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:unpack-path ,(string-append "gx/ipfs/" ipfs-hash "/go-ipfs-config")
+         #:import-path ,(string-append "gx/ipfs/" ipfs-hash "/go-ipfs-config")))
+      (home-page
+       "https://github.com/ipfs/go-ipfs-cmdkit")
+      (synopsis "Shared types, functions and values for go-ipfs")
+      (description "@command{cmdkit} offers some types, functions and values
+that are shared between @command{go-ipfs/commands} and its rewrite @command{go-ipfs-cmds}.")
+      (license license:expat))))
+
 (define-public go-github-com-ipfs-go-ipfs-cmdkit-files
   (let ((commit
           "386fcf8f18a185ec121676665fe2d9574496048d")