summary refs log tree commit diff
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2023-06-20 18:55:35 +0000
committer宋文武 <iyzsong@member.fsf.org>2023-07-18 20:23:42 +0800
commitbd0e7c5e177df3183ad5f4f5a74d249897c92ed2 (patch)
tree3c78303fe92520b37ae050dcdfd3b64410c32b11
parent3c79f4b50abba1e370da4d2a808cc6bfc4336654 (diff)
downloadguix-bd0e7c5e177df3183ad5f4f5a74d249897c92ed2.tar.gz
gnu: zsh: Update to 5.9.
* gnu/packages/shells.scm (zsh): Update to 5.9.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/shells.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 16a4bba92f..0dae9ee954 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -460,7 +460,7 @@ history mechanism, job control and a C-like syntax.")
 (define-public zsh
   (package
     (name "zsh")
-    (version "5.8.1")
+    (version "5.9")
     (source (origin
               (method url-fetch)
               (uri (list (string-append
@@ -471,7 +471,7 @@ history mechanism, job control and a C-like syntax.")
                            ".tar.xz")))
               (sha256
                (base32
-                "06crvpqbpm8sq5c215f4b985z7npwnqnj0i0g53hnq6fp8h3b5xn"))
+                "1mdc8lnq8qxq1ahxp8610n799pd7a9kqg3liy7xq2pjvvp71x3cv"))
               (patches (search-patches "zsh-egrep-failing-test.patch"))))
     (build-system gnu-build-system)
     (arguments `(#:configure-flags