summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-01 17:35:23 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-01 17:35:23 -0400
commitc722bc034ed5f8de39a001658d6907cde67f1468 (patch)
tree64ad837733e8fb03c5ac8d2aed4136259f3e38f2
parent107fbc375eb177e7731dc10d1821c383282fc492 (diff)
downloadguix-c722bc034ed5f8de39a001658d6907cde67f1468.tar.gz
gnu: Add imgui-1.87.
* gnu/packages/toolkits.scm (imgui-1.87): New variable.
-rw-r--r--gnu/packages/toolkits.scm18
1 files changed, 17 insertions, 1 deletions
diff --git a/gnu/packages/toolkits.scm b/gnu/packages/toolkits.scm
index a29ab01154..23c1877edd 100644
--- a/gnu/packages/toolkits.scm
+++ b/gnu/packages/toolkits.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2020, 2022 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
 ;;;
@@ -132,6 +132,22 @@ applications, full-screen applications, and embedded platforms without
 standard operating system features.")
     (license license:expat)))
 
+(define-public imgui-1.87
+  (package
+    (inherit imgui)
+    (name "imgui")
+    (version "1.87")
+    (source (origin
+              (inherit (package-source imgui))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/ocornut/imgui")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "10qil22s5qak3as41787iz273sibpq1bq66bakgn7yvhj5fym6hz"))))))
+
 (define-public imgui-1.86
   (package
     (inherit imgui)