summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-03-12 17:07:04 +0100
committerLudovic Courtès <ludo@gnu.org>2019-03-12 23:51:32 +0100
commitc9c51ac39aae7a4a49c8125916740f340fdfd4f7 (patch)
tree7bff7e1fb5b0f182b944bf9c7ad48a96234a9a43
parent29e76f07223bed1520a19d273ada5fc48fba141d (diff)
downloadguix-c9c51ac39aae7a4a49c8125916740f340fdfd4f7.tar.gz
Revert "packages: 'package-input-rewriting' can take a promise."
This reverts commit 7d2be1277b44de9d0528d9d3015443b40cb3b104, which
turned out to be unhelpful for the problem at hand:

  https://lists.gnu.org/archive/html/guix-devel/2019-01/msg00486.html
-rw-r--r--gnu/packages/guile.scm2
-rw-r--r--guix/packages.scm16
2 files changed, 5 insertions, 13 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index eb32e596d3..daeadca610 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -391,7 +391,7 @@ GNU@tie{}Guile.  Use the @code{(ice-9 readline)} module and call its
 (define package-for-guile-2.0
   ;; A procedure that rewrites the dependency tree of the given package to use
   ;; GUILE-2.0 instead of GUILE-2.2.
-  (package-input-rewriting (delay `((,guile-2.2 . ,guile-2.0)))
+  (package-input-rewriting `((,guile-2.2 . ,guile-2.0))
                            (guile-variant-package-name "guile2.0")))
 
 (define-public guile-for-guile-emacs
diff --git a/guix/packages.scm b/guix/packages.scm
index 8515bb7c6f..f191327718 100644
--- a/guix/packages.scm
+++ b/guix/packages.scm
@@ -855,27 +855,19 @@ when CUT? returns true for a given package."
                                   #:optional (rewrite-name identity))
   "Return a procedure that, when passed a package, replaces its direct and
 indirect dependencies (but not its implicit inputs) according to REPLACEMENTS.
-REPLACEMENTS is a list of package pairs or a promise thereof; the first
-element of each pair is the package to replace, and the second one is the
-replacement.
+REPLACEMENTS is a list of package pairs; the first element of each pair is the
+package to replace, and the second one is the replacement.
 
 Optionally, REWRITE-NAME is a one-argument procedure that takes the name of a
 package and returns its new name after rewrite."
   (define (rewrite p)
-    (match (assq-ref (if (promise? replacements)
-                         (force replacements)
-                         replacements)
-                     p)
+    (match (assq-ref replacements p)
       (#f  (package
              (inherit p)
              (name (rewrite-name (package-name p)))))
       (new new)))
 
-  (package-mapping rewrite
-                   (lambda (package)
-                     (assq package (if (promise? replacements)
-                                       (force replacements)
-                                       replacements)))))
+  (package-mapping rewrite (cut assq <> replacements)))
 
 (define-syntax-rule (package/inherit p overrides ...)
   "Like (package (inherit P) OVERRIDES ...), except that the same