summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-01-19 12:52:35 +0200
committerMark H Weaver <mhw@netris.org>2016-02-24 11:49:57 -0500
commitcda6aaf0794bfb84d737a3a850ac5e7508cc3c1b (patch)
treea870816f97fec513247665128665527e9ba801b3
parentdb12dac05c03d1d0ca03479e09102f714866a2b8 (diff)
downloadguix-cda6aaf0794bfb84d737a3a850ac5e7508cc3c1b.tar.gz
gnu: gst-plugins-base: Use 'modify-phases'.
* gnu/packages/gstreamer.scm (gst-plugins-base)[arguments]: Use
'modify-phases'.
-rw-r--r--gnu/packages/gstreamer.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 3aec87e25f..45dded1a6e 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -180,12 +180,11 @@ This package provides the core library and elements.")
                             (assoc-ref %outputs "doc")
                             "/share/gtk-doc/html"))
        #:phases
-       (alist-cons-before
-        'configure 'patch
-        (lambda _
-          (substitute* "tests/check/libs/pbutils.c"
-            (("/bin/sh") (which "sh"))))
-        %standard-phases)))
+       (modify-phases %standard-phases
+         (add-before 'configure 'patch
+           (lambda _
+             (substitute* "tests/check/libs/pbutils.c"
+               (("/bin/sh") (which "sh"))))))))
     (home-page "http://gstreamer.freedesktop.org/")
     (synopsis
      "Plugins for the GStreamer multimedia library")