summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2022-03-24 22:47:18 -0400
committerLeo Famulari <leo@famulari.name>2022-03-24 22:50:20 -0400
commitd05fcc21cb9509084a0424e6808b84b58dc52d62 (patch)
tree511d12ffdd046c3630319cd4cf6efa6a143a9314
parentf252e6b8bf539db4ebc811aff40670af7cf26308 (diff)
downloadguix-d05fcc21cb9509084a0424e6808b84b58dc52d62.tar.gz
gnu: tremc: Update to 0.9.3.
* gnu/packages/bittorrent.scm (tremc): Update to 0.9.3.
[source]: Remove obsolete patch.
* gnu/packages/patches/tremc-fix-decodestring.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/bittorrent.scm5
-rw-r--r--gnu/packages/patches/tremc-fix-decodestring.patch25
3 files changed, 2 insertions, 29 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 05b787ac9b..e2c2c326e3 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1862,7 +1862,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/transcode-ffmpeg.patch	\
   %D%/packages/patches/transfig-gcc10-fno-common.patch		\
   %D%/packages/patches/transmission-honor-localedir.patch	\
-  %D%/packages/patches/tremc-fix-decodestring.patch		\
   %D%/packages/patches/trytond-add-egg-modules-to-path.patch	\
   %D%/packages/patches/trytond-add-guix_trytond_path.patch	\
   %D%/packages/patches/ttf2eot-cstddef.patch			\
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 0e939d93ac..0191bb8e1b 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -226,7 +226,7 @@ XML-RPC over SCGI.")
 (define-public tremc
   (package
     (name "tremc")
-    (version "0.9.2")
+    (version "0.9.3")
     (source
      (origin
        (method git-fetch)
@@ -236,8 +236,7 @@ XML-RPC over SCGI.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "1fqspp2ckafplahgba54xmx0sjidx1pdzyjaqjhz0ivh98dkx2n5"))
-       (patches (search-patches "tremc-fix-decodestring.patch"))))
+         "11izsgwj435skkgvw96an6ddcm1hk3ff1gji4ksnidlyv6g6npyv"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f                      ; no test suite
diff --git a/gnu/packages/patches/tremc-fix-decodestring.patch b/gnu/packages/patches/tremc-fix-decodestring.patch
deleted file mode 100644
index 346f65e611..0000000000
--- a/gnu/packages/patches/tremc-fix-decodestring.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 79995bc82e81f0429222aab4d90a03440feef057 Mon Sep 17 00:00:00 2001
-From: Matan Ziv-Av <matan@svgalib.org>
-Date: Mon, 29 Jun 2020 15:18:03 +0300
-Subject: [PATCH] Use base64.decodebytes.
-
-Based on upstream commit 79995bc82e81f0429222aab4d90a03440feef057 which
-confuses several unrelated changes.
-
----
- tremc | 29 ++++++++++++++++++++++++++++-
- 1 file changed, 28 insertions(+), 1 deletion(-)
-
-diff --git a/tremc b/tremc
-index b47f012..c626fde 100755
---- a/tremc
-+++ b/tremc
-@@ -440,7 +443,7 @@ class Transmission(object):
-                 # TAG_TORRENT_DETAILS, but just passing seems to help.(?)
-                 try:
-                     torrent_details = response['arguments']['torrents'][0]
--                    torrent_details['pieces'] = base64.decodestring(bytes(torrent_details['pieces'], ENCODING))
-+                    torrent_details['pieces'] = base64.decodebytes(bytes(torrent_details['pieces'], ENCODING))
-                     self.torrent_details_cache = torrent_details
-                     self.upgrade_peerlist()
-                 except IndexError: