summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-07-20 21:38:34 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-07-20 21:41:48 +0300
commitd68d84ee190dcc255732ecde6b37b925a9edd22c (patch)
tree36ab5c2812ae603d134080ed7d7fdb085be7c69a
parentc4413569f7648ad64b5eb998a30379a117386251 (diff)
downloadguix-d68d84ee190dcc255732ecde6b37b925a9edd22c.tar.gz
gnu: gpodder: Make the check phase honor the tests? argument.
* gnu/packages/gpodder.scm (gpodder)[arguments]: Adjust custom 'check
phase to skip tests when #:tests? is #f.
-rw-r--r--gnu/packages/gpodder.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/gpodder.scm b/gnu/packages/gpodder.scm
index 13a75d4fd4..5a18a16753 100644
--- a/gnu/packages/gpodder.scm
+++ b/gnu/packages/gpodder.scm
@@ -93,11 +93,12 @@
                  (("xdg-open") (string-append xdg-utils "/bin/xdg-open")))
                #t)))
          (replace 'check
-           (lambda _
+           (lambda* (#:key tests? #:allow-other-keys)
              ; The `unittest' target overrides the PYTHONPATH variable.
              (substitute* "makefile"
                (("PYTHONPATH=src/") "PYTHONPATH=${PYTHONPATH}:src/"))
-             (invoke "make" "unittest")))
+             (when tests?
+               (invoke "make" "unittest"))))
          ;; 'msgmerge' introduces non-determinism by resetting the
          ;; POT-Creation-Date in .po files.
          (add-before 'install 'do-not-run-msgmerge