summary refs log tree commit diff
diff options
context:
space:
mode:
authorJoseph LaFreniere <joseph@lafreniere.xyz>2020-11-08 21:36:52 -0600
committerEfraim Flashner <efraim@flashner.co.il>2021-01-03 17:24:28 +0200
commitda3335b5f6a412f628594c8cc483bb5b1fb88311 (patch)
tree42b740db5e0204324d5f91973adf5a0d0ece2e5e
parent0d8f28e9de3e14b5eba58e551b674f54a3294aae (diff)
downloadguix-da3335b5f6a412f628594c8cc483bb5b1fb88311.tar.gz
gnu: Add go-github-com-daviddengcn-go-colortext.
* gnu/packages/golang.scm (go-github-com-daviddengcn-go-colortext): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/golang.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 64afc4b48d..e492c6077f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -507,6 +507,33 @@ jar struct to manage the cookies added to the cookie jar.")
     (description "This package provides additions to Go's stdlib @code{fmt}.")
     (license license:bsd-3)))
 
+(define-public go-github-com-daviddengcn-go-colortext
+  (package
+    (name "go-github-com-daviddengcn-go-colortext")
+    (version "1.0.0")
+    (home-page "https://github.com/daviddengcn/go-colortext")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url home-page)
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32 "0j5ldwg3a768d3nniiglghr9axj4p87k7f7asqxa1a688xvcms48"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/daviddengcn/go-colortext"))
+    (native-inputs
+     `(("go-github-com-golangplus-testing" ,go-github-com-golangplus-testing)))
+    (synopsis "Change the color of console text and background")
+    (description
+     "This is a package to change the color of the text and background in the
+console, working both under Windows and other systems.
+
+Under Windows, the console APIs are used.  Otherwise, ANSI texts are output.")
+    ;; dual-licensed
+    (license (list license:bsd-3 license:expat))))
+
 (define-public go-github-com-golangplus-testing
   (package
     (name "go-github-com-golangplus-testing")