summary refs log tree commit diff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-11-07 15:11:44 -0500
committerJohn Kehayias <john.kehayias@protonmail.com>2023-11-07 15:12:06 -0500
commite452227a51131ed97a41a930d77732ebb7ff568a (patch)
tree89e37770cf92fdd4de4d4017f219e9b6abc682d7
parente4f42164e93163d376cf1f842feffbd1c35ae72a (diff)
downloadguix-e452227a51131ed97a41a930d77732ebb7ff568a.tar.gz
gnu: mbedtls-apache: Update to 2.28.5.
This fixes mbedtls-apache failing some tests for unknown reasons after recent
updates and ungrafting to other packages.  This should soon be renamed to
mbedtls-apache-lts and a newer version added; see
<https://issues.guix.gnu.org/66718>.

* gnu/packages/tls.scm (mbedtls-apache): Update to 2.28.5.

Change-Id: Ie513c11cb60262be9865ebbd1f6238d39f299c42
-rw-r--r--gnu/packages/tls.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 6a0aaf7f14..75e6370c72 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -991,7 +991,7 @@ number generator")
     (name "mbedtls-apache")
     ;; XXX Check whether ‘-Wformat-signedness’ still breaks mbedtls-for-hiawatha
     ;; when updating.
-    (version "2.28.0")
+    (version "2.28.5")
     (source
      (origin
        (method git-fetch)
@@ -1000,7 +1000,7 @@ number generator")
              (commit (string-append "mbedtls-" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0s37dsi29v7146fi9k4frvx5rz2snxdm6c3rwq2fvnca2r80hfjl"))))
+        (base32 "1jlkvvyigpjvv404b8vmx68f1v6g1h2zr6rd78dhc0xgqi018phs"))))
     (build-system cmake-build-system)
     (arguments
      `(#:configure-flags