summary refs log tree commit diff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-03-24 18:09:38 +0000
committerChristopher Baines <mail@cbaines.net>2019-04-14 10:45:58 +0100
commite748fbe2acfc3cfc5a0d7e3bbcaefb0b01ac5880 (patch)
treea2963659b386d07c036b120e747d90171651305d
parentf73d4b1fdc151b8449297d06f790eec03e208260 (diff)
downloadguix-e748fbe2acfc3cfc5a0d7e3bbcaefb0b01ac5880.tar.gz
gnu: Add perl-string-formatter.
* gnu/packages/perl.scm (perl-string-formatter): New variable.
-rw-r--r--gnu/packages/perl.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index fcd946f37c..f1131a0713 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -7669,6 +7669,32 @@ expanding standard C/Unix-style backslash escapes like \n and \t, wrapping and
 removing double-quotes, and truncating to fit within a desired length.")
     (license (package-license perl))))
 
+(define-public perl-string-formatter
+  (package
+    (name "perl-string-formatter")
+    (version "0.102084")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://cpan/authors/id/R/RJ/RJBS/String-Formatter-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "0mlwm0rirv46gj4h072q8gdync5zxxsxy8p028gdyrhczl942dc3"))))
+    (build-system perl-build-system)
+    (propagated-inputs
+     `(("perl-params-util" ,perl-params-util)
+       ("perl-sub-exporter" ,perl-sub-exporter)))
+    (home-page "https://metacpan.org/release/String-Formatter")
+    (synopsis "Build your own sprintf-like functions")
+    (description
+     "@code{String::Formatter} is a tool for building sprintf-like formatting
+routines.  It supports named or positional formatting, custom conversions,
+fixed string interpolation, and simple width-matching.")
+    (license gpl2)))
+
 (define-public perl-string-rewriteprefix
   (package
     (name "perl-string-rewriteprefix")