summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-09 02:00:03 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-09 02:00:09 +0200
commitef64cc509ed311cc7cab30daa8fbfee7495180bc (patch)
tree449b39868467380dd4ab33373cc8c56e45d4edc0
parent6e0c8f097bf3dea498f7e443c89cb2228d3b38f5 (diff)
downloadguix-ef64cc509ed311cc7cab30daa8fbfee7495180bc.tar.gz
gnu: xtl: Use G-expressions.
* gnu/packages/cpp.scm (xtl)[arguments]:
Rewrite as G-expressions.
-rw-r--r--gnu/packages/cpp.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 0ea80ea237..ec1f4cd325 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -691,14 +691,15 @@ intuitive syntax and trivial integration.")
     (native-inputs
      (list doctest googletest nlohmann-json))
     (arguments
-     '(#:configure-flags
-       '("-DBUILD_TESTS=ON")
-       #:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* _
-             (with-directory-excursion "test"
-               (invoke "./test_xtl")))))))
+     (list
+      #:configure-flags
+      #~(list "-DBUILD_TESTS=ON")
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'check
+            (lambda _
+              (with-directory-excursion "test"
+                (invoke "./test_xtl")))))))
     (home-page "https://github.com/QuantStack/xtl")
     (build-system cmake-build-system)
     (synopsis "C++ template library providing some basic tools")