summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-06-25 15:53:30 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-06-25 18:42:49 +0200
commitf378f1d05fb9a5ec5502147c360cf4cf0c7cff7d (patch)
treeb6712b5abb25d8e7ebfb554418163f2b64226b98
parentb8418eeed4b561447aa9b8c58b65e2e0b2917e14 (diff)
downloadguix-f378f1d05fb9a5ec5502147c360cf4cf0c7cff7d.tar.gz
gnu: exfat-utils: Move to (gnu packages file-systems).
* gnu/packages/mtools.scm (exfat-utils): Move from here…
* gnu/packages/file-systems.scm (exfat-utils): …to here.
-rw-r--r--gnu/packages/file-systems.scm21
-rw-r--r--gnu/packages/mtools.scm21
2 files changed, 21 insertions, 21 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 0b46ecb4c1..cb77d600c1 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -320,6 +320,27 @@ always possible.")
     (license (list license:bsd-2        ; src/fuse_kernel.h
                    license:gpl3+))))    ; everything else
 
+(define-public exfat-utils
+  (package
+    (name "exfat-utils")
+    (version "1.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/relan/exfat/releases/download/v"
+             version "/exfat-utils-" version ".tar.gz"))
+       (sha256
+        (base32 "0da8f8mm1sbwqp7prh78qk33xm0b8kk2d5is7mh2szlhgdxd1syz"))))
+    (build-system gnu-build-system)
+    (home-page "https://github.com/relan/exfat")
+    (synopsis "Utilities to manipulate exFAT file systems")
+    (description
+     "This package provides an implementation of the exFAT file system,
+including command-line tools to validate exFAT file systems and to create new
+ones.")
+    (license license:gpl2+)))
+
 (define-public fsarchiver
   (package
     (name "fsarchiver")
diff --git a/gnu/packages/mtools.scm b/gnu/packages/mtools.scm
index 49f9b8951e..147d19917b 100644
--- a/gnu/packages/mtools.scm
+++ b/gnu/packages/mtools.scm
@@ -48,24 +48,3 @@ or Unix system.  It supports long file names and multiple disk formats.  It
 also supports some FAT-specific features such as volume labels and
 FAT-specific file attributes.")
     (license gpl3+)))
-
-(define-public exfat-utils
-  (package
-    (name "exfat-utils")
-    (version "1.3.0")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://github.com/relan/exfat/releases/download/v"
-                    version "/" name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "0da8f8mm1sbwqp7prh78qk33xm0b8kk2d5is7mh2szlhgdxd1syz"))))
-    (build-system gnu-build-system)
-    (home-page "https://github.com/relan/exfat")
-    (synopsis "Utilities to manipulate exFAT file systems")
-    (description
-     "This package provides an implementation of the exFAT file system,
-including command-line tools to validate exFAT file systems and to create new
-ones.")
-    (license gpl2+)))