summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-03-08 16:10:39 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-03-09 02:33:30 +0100
commitf45cc966baffb061353cf9f9ead4667b2af82efc (patch)
tree8e51a219007b64770e5e1b0b849319d40f7b390b
parenta48db08afe3e43c568c49a94d55bf3c93357bb03 (diff)
downloadguix-f45cc966baffb061353cf9f9ead4667b2af82efc.tar.gz
gnu: i3lock-color: Don't use unstable tarball.
* gnu/packages/wm.scm (i3lock-color)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
-rw-r--r--gnu/packages/wm.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 06dada269c..68010136f2 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -392,16 +392,16 @@ prompt.")
     (version "2.11-c")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/PandorasFox/i3lock-color/"
-                           "archive/" version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/PandorasFox/i3lock-color.git")
+             (commit version)))
+       (file-name (git-file-name name version))
        (sha256
-        (base32
-         "0zh7il2y6dmzym3w6r9xii5dma8pjjjlq4dm5iby7m3gvplj4q9p"))))
+        (base32 "1myq9fazkwd776agrnj27bm5nwskvss9v9a5qb77n037dv8d0rdw"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f))                              ;no tests included
+     `(#:tests? #f))                    ; no tests included
     (inputs
      `(("cairo" ,cairo)
        ("libev" ,libev)