summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-12-06 11:12:15 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-12-06 11:29:07 +0200
commitf635f725778f86abaa77f674f8f670f74bffd7be (patch)
treeb9fc4024e2f1095803bc570d823b7da0e2470de4
parented18b697c4783f139e23731f5bd0b0ed197997bb (diff)
downloadguix-f635f725778f86abaa77f674f8f670f74bffd7be.tar.gz
gnu: vdirsyncer: Update to 0.19.0.
* gnu/packages/dav.scm (vdirsyncer): Update to 0.19.0.
[arguments]: Remove trailing #t in phases. Remove phase generating the
manpage.
[native-inputs]: Add python-aioresponses, python-click, python-trustme,
python-pytest-asyncio, python-pytest-cov, python-pytest-httpserver.
Remove python-pytest-localserver, python-pytest-subtesthack,
python-urllib3, python-wsgi-interpreter.
[inputs]: Remove field.
[propagated-inputs]: Add python-aiohttp, python-aiostream. Remove
python-click-threading.
* gnu/packages/python-xyz.scm (python-click-5): Remove variable.
-rw-r--r--gnu/packages/dav.scm39
-rw-r--r--gnu/packages/python-xyz.scm12
2 files changed, 15 insertions, 36 deletions
diff --git a/gnu/packages/dav.scm b/gnu/packages/dav.scm
index 9a336b381e..775a3d9bed 100644
--- a/gnu/packages/dav.scm
+++ b/gnu/packages/dav.scm
@@ -122,14 +122,13 @@ efficient syncing
 (define-public vdirsyncer
   (package
     (name "vdirsyncer")
-    ;; When updating, check whether python-click-5 can be removed entirely.
-    (version "0.18.0")
+    (version "0.19.0")
     (source (origin
              (method url-fetch)
              (uri (pypi-uri name version))
              (sha256
               (base32
-               "00f2bw1a2jbbd1sbci0swnd67kylr341aa9rpbxkajbp3zakxg17"))))
+               "0995bavlv8s9j0127ncq3yzy5p72lam9qgpswyjfanc6l01q87lf"))))
     (build-system python-build-system)
     (arguments
      `(#:tests? #f ; The test suite is very flakey.
@@ -141,38 +140,30 @@ efficient syncing
             (setenv "DAV_SERVER" "radicale")
             (setenv "REMOTESTORAGE_SERVER" "skip")
             (if tests?
-                (invoke "make" "test")
-                #t)))
+                (invoke "make" "test"))))
         (add-after 'unpack 'patch-version-call
           (lambda _
             (substitute* "docs/conf.py"
-              (("^release.*") (string-append "release = '" ,version "'\n")))
-            #t))
-        (add-after 'install 'manpage
-          (lambda* (#:key inputs outputs #:allow-other-keys)
-            (invoke "make" "--directory=docs/" "man")
-            (install-file
-              "docs/_build/man/vdirsyncer.1"
-              (string-append
-                (assoc-ref outputs "out")
-                "/share/man/man1"))
-            #t)))))
+              (("^release.*") (string-append "release = '" ,version "'\n"))))))))
     (native-inputs
      (list python-setuptools-scm
            python-sphinx
            ;; Required for testing
+           python-aioresponses
            python-hypothesis
+           python-trustme
            python-pytest
-           python-pytest-localserver
-           python-pytest-subtesthack
-           python-urllib3
-           python-wsgi-intercept
+           python-pytest-asyncio
+           python-pytest-cov
+           python-pytest-httpserver
            radicale))
-    (inputs
-     (list ;; XXX https://github.com/mitsuhiko/click/issues/200
-           python-click-5))
     (propagated-inputs
-     (list python-atomicwrites python-click-log python-click-threading
+     (list python-aiohttp
+           python-aiostream
+           python-atomicwrites
+           python-click
+           python-click-log
+           python-requests
            python-requests-toolbelt))
     (synopsis "Synchronize calendars and contacts")
     (description "Vdirsyncer synchronizes your calendars and addressbooks
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0f47e3be4f..b74b120510 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3671,18 +3671,6 @@ with sensible defaults out of the box.")
         (base32 "06kbzd6sjfkqan3miwj9wqyddfxc2b6hi7p5s4dvqjb3gif2bdfj"))))
     (arguments `())))
 
-(define-public python-click-5
-  (package (inherit python-click)
-    (name "python-click")
-    (version "5.1")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "click" version))
-       (sha256
-        (base32 "0njsm0wn31l21bi118g5825ma5sa3rwn7v2x4wjd7yiiahkri337"))))
-    (arguments `())))
-
 (define-public python-cligj
   (package
     (name "python-cligj")