summary refs log tree commit diff
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-03-06 13:40:24 +0800
committer宋文武 <iyzsong@gmail.com>2016-03-07 09:57:20 +0800
commitfa7cf82ebe5ca1516843e92fe63bcea863cf98a2 (patch)
tree357fcab61fd8839983dee52ce010b1486d703eed
parente28f95a96369051f3f5110fd89ad7b48e5792c67 (diff)
downloadguix-fa7cf82ebe5ca1516843e92fe63bcea863cf98a2.tar.gz
gnu: python-pygobject: Propagate glib and libffi.
* gnu/packages/glib.scm (python-pygobject): Move glib and libffi to propagated-inputs.
(python2-pygobject)[inputs]: Remove glib and libffi.
-rw-r--r--gnu/packages/glib.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index dda8640531..bc69af5a9e 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -534,9 +534,11 @@ useful for C++.")
        ("pkg-config" ,pkg-config)))
     (inputs
      `(("python" ,python)
-       ("glib"   ,glib)
        ("python-pycairo" ,python-pycairo)
-       ("gobject-introspection" ,gobject-introspection)
+       ("gobject-introspection" ,gobject-introspection)))
+    (propagated-inputs
+     ;; pygobject-3.0.pc refers to all these.
+     `(("glib" ,glib)
        ("libffi" ,libffi)))
     (arguments
      ;; TODO: failing tests: test_native_calls_async
@@ -562,10 +564,8 @@ useful for C++.")
     (name "python2-pygobject")
     (inputs
      `(("python" ,python-2)
-       ("glib" ,glib)
        ("python-pycairo" ,python2-pycairo)
-       ("gobject-introspection" ,gobject-introspection)
-       ("libffi" ,libffi)))))
+       ("gobject-introspection" ,gobject-introspection)))))
 
 (define telepathy-glib
   (package