about summary refs log tree commit diff
path: root/configuration.nix
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2022-05-12 14:28:54 +0900
committerNguyễn Gia Phong <mcsinyx@disroot.org>2022-05-12 14:28:54 +0900
commit1c2a3ebe9da70a85589c3adcf5087281a95ac7b4 (patch)
treea0e32f9634a1246202daf2b4ebb8cabd24415308 /configuration.nix
parent6753ad7cad7ea720fea73c91bff9df6f27d80368 (diff)
downloadnixos-conf-1c2a3ebe9da70a85589c3adcf5087281a95ac7b4.tar.gz
Set up ipwhl.loang.net
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix52
1 files changed, 7 insertions, 45 deletions
diff --git a/configuration.nix b/configuration.nix
index c68d76b..9e00c0a 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -20,8 +20,9 @@ in {
   } "${config.services.nginx.virtualHosts.${domain}.root}/~";
 
   imports = [
-    ./vpsadminos.nix
+    ./ipfs.nix
     ./matrix.nix
+    ./vpsadminos.nix
   ];
 
   networking = {
@@ -46,18 +47,6 @@ in {
   security = {
     acme = {
       acceptTerms = true;
-      certs.${domain} = {
-        credentialsFile = pkgs.writeText "namesilo.env" ''
-          NAMESILO_API_KEY_FILE=/var/lib/acme/namesilo.key
-          NAMESILO_PROPAGATION_TIMEOUT=1800
-        '';
-        dnsProvider = "namesilo";
-        extraDomainNames = [
-          "*.ipfs.${domain}"
-          "*.ipns.${domain}"
-        ];
-        webroot = null;
-      };
       defaults.email = "mcsinyx@disroot.org";
     };
 
@@ -69,18 +58,6 @@ in {
   };
 
   services = {
-    ipfs = {
-      enable = true;
-      enableGC = true;
-      extraConfig.GateWay = {
-        NoFetch = true;
-        PublicGateways.${domain} = {
-          Paths =  [ "/ipfs" "/ipns" ];
-          UseSubdomains = true;
-        };
-      };
-    };
-
     molly-brown = {
       certPath = "${certs.directory}/cert.pem";
       docBase = "/var/lib/gemini/${domain}";
@@ -89,28 +66,13 @@ in {
       keyPath = "${certs.directory}/key.pem";
     };
 
-    nginx = let
-      ipfsGateway = "http://localhost:8080";
-      ipfsProxy = {
-        forceSSL = true;
-        locations."/".proxyPass = ipfsGateway;
-        useACMEHost = domain;
-      };
-    in {
+    nginx = {
       enable = true;
       recommendedProxySettings = true;
-      virtualHosts = {
-        "${domain}" = {
-          enableACME = true;
-          forceSSL = true;
-          locations = {
-            "/ipfs".proxyPass = ipfsGateway;
-            "/ipns".proxyPass = ipfsGateway;
-          };
-          root = "/var/lib/www/${domain}";
-        };
-        "*.ipfs.${domain}" = ipfsProxy;
-        "*.ipns.${domain}" = ipfsProxy;
+      virtualHosts.${domain} = {
+        enableACME = true;
+        forceSSL = true;
+        root = "/var/lib/www/${domain}";
       };
     };