about summary refs log tree commit diff
path: root/dns.nix
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2023-02-12 02:14:43 +0900
committerNguyễn Gia Phong <mcsinyx@disroot.org>2023-02-12 02:14:43 +0900
commit426235c17e4d6557744701a86783907351708af7 (patch)
tree12cb32aafb06635a0ccf455012b3626aac985db1 /dns.nix
parent512571a3e9b4a690951db30cc027441452efc4a1 (diff)
downloadnixos-conf-426235c17e4d6557744701a86783907351708af7.tar.gz
Dogfood our authoritative DNS server
Diffstat (limited to 'dns.nix')
-rw-r--r--dns.nix19
1 files changed, 12 insertions, 7 deletions
diff --git a/dns.nix b/dns.nix
index 307e930..35f6676 100644
--- a/dns.nix
+++ b/dns.nix
@@ -40,18 +40,21 @@
           any: info
 
       acl:
+        - id: lego
+          address: 127.0.0.1
+          address: ::1
+          key: lego
+          action: update
+          update-type: TXT
+          update-owner: key
         - id: secondary
           address: 204.87.183.53
           address: 2607:7c80:54:6::53
           action: transfer
-        - id: cnx
-          action: update
-          update-owner: key
-          key: cnx.gdn
         - id: xarvos
+          key: xrvs.net
           action: update
           update-owner: key
-          key: xrvs.net
 
       template:
         - id: default
@@ -63,15 +66,17 @@
         - domain: cnx.gdn
           notify: secondary
           acl: secondary
-          acl: cnx
         - domain: loang.net
+          notify: secondary
+          acl: lego
+          acl: secondary
         - domain: xrvs.net
           notify: secondary
           acl: secondary
           acl: xarvos
     '';
     keyFiles = [
-      "/var/lib/knot/keys/update/cnx.gdn"
+      "/var/lib/knot/keys/update/lego"
       "/var/lib/knot/keys/update/xrvs.net"
     ];
   };