about summary refs log tree commit diff
path: root/git.nix
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2023-03-07 18:00:22 +0900
committerNguyễn Gia Phong <mcsinyx@disroot.org>2023-03-07 18:02:18 +0900
commite0d6ebfc8fdc00415ff16cfc10e83d4b49e769d8 (patch)
treeab1194df4b333052dc177274d0cda138ce1fd048 /git.nix
parentbb1c3ca919c58ed47a09813831c7ffc790a5f0d3 (diff)
downloadnixos-conf-e0d6ebfc8fdc00415ff16cfc10e83d4b49e769d8.tar.gz
Set up cgit
Diffstat (limited to 'git.nix')
-rw-r--r--git.nix53
1 files changed, 53 insertions, 0 deletions
diff --git a/git.nix b/git.nix
new file mode 100644
index 0000000..152de98
--- /dev/null
+++ b/git.nix
@@ -0,0 +1,53 @@
+# HTTP Git hosting
+# Copyright (C) 2023  Nguyễn Gia Phong
+#
+# This file is part of loang configuration.
+#
+# Loang configuration is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as published
+# by the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# Loang configuration is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public License
+# along with loang configuration.  If not, see <https://www.gnu.org/licenses/>.
+
+{ config, lib, pkgs, ... }:
+let inherit (config.networking) domain;
+in {
+  services = {
+    lighttpd = {
+      cgit = {
+        configText = let
+          httpsClone = "https://trong.${domain}/$CGIT_REPO_URL";
+          scanPath = "/var/lib/git";
+          sshClone = "ssh://${domain}:2211${scanPath}/$CGIT_REPO_URL";
+        in ''
+          about-filter=${pkgs.cgit}/lib/cgit/filters/about-formatting.sh
+          source-filter=${pkgs.cgit}/lib/cgit/filters/syntax-highlighting.py
+
+          clone-url=${httpsClone} ${sshClone}
+          enable-blame=1
+          enable-git-config=1
+          readme=:README.md
+          snapshots=tar.gz tar.zst
+          scan-path=${scanPath}
+        '';
+        enable = true;
+        subdir = "";
+      };
+      enable = true;
+      port = 9418;
+    };
+
+    nginx."trong.${domain}" = let port = config.services.lighttpd.port;
+    in {
+      enableACME = true;
+      forceSSL = true;
+      locations."/".proxyPass = "http://127.0.0.1:${toString port}";
+    };
+}