about summary refs log tree commit diff
path: root/ipfs.nix
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2023-02-21 06:59:08 +0900
committerNguyễn Gia Phong <mcsinyx@disroot.org>2023-02-21 07:01:00 +0900
commit2ce14f17f2700f3188e3467d35fa218c018e9c73 (patch)
treef3956e3f6ad2428ab9d5e3fd55e684ce3a3050b5 /ipfs.nix
parentbfa417e9a2790cd506393559207a751201d2159d (diff)
downloadnixos-conf-2ce14f17f2700f3188e3467d35fa218c018e9c73.tar.gz
Clean up
Diffstat (limited to 'ipfs.nix')
-rw-r--r--ipfs.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/ipfs.nix b/ipfs.nix
index 5122c67..876b74c 100644
--- a/ipfs.nix
+++ b/ipfs.nix
@@ -16,8 +16,8 @@
 # You should have received a copy of the GNU Affero General Public License
 # along with loang configuration.  If not, see <https://www.gnu.org/licenses/>.
 
-{ config, lib, pkgs, ... }:
-let domain = config.networking.domain;
+{ config, ... }:
+let inherit (config.networking) domain;
 in {
   networking.firewall = {
     allowedTCPPorts = [ 4001 ];
@@ -26,7 +26,7 @@ in {
 
   security = {
     acme.certs.${domain} = {
-      credentialsFile = pkgs.writeText "knot.env" ''
+      credentialsFile = builtins.toFile "knot.env" ''
         RFC2136_NAMESERVER=127.0.0.1
         RFC2136_TSIG_KEY=lego
         RFC2136_TSIG_ALGORITHM=hmac-sha256