about summary refs log tree commit diff
path: root/matrix.nix
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2023-02-21 15:03:17 +0900
committerNguyễn Gia Phong <mcsinyx@disroot.org>2023-02-21 15:03:17 +0900
commit95859c41afd89ab97eca87819b4adaff672e8508 (patch)
tree498012a7d50cbaa8ce05463bf4c935eaec117b6a /matrix.nix
parentac30f18118da23914a6f88134f39f2199d6213bb (diff)
downloadnixos-conf-95859c41afd89ab97eca87819b4adaff672e8508.tar.gz
Use PostgreSQL for 소주
Diffstat (limited to 'matrix.nix')
-rw-r--r--matrix.nix21
1 files changed, 2 insertions, 19 deletions
diff --git a/matrix.nix b/matrix.nix
index 12a7655..cdd75cc 100644
--- a/matrix.nix
+++ b/matrix.nix
@@ -103,28 +103,11 @@ in {
     };
 
     postgresql = {
-      enable = true;
       ensureDatabases = [ "dendrite" ];
-      ensureUsers = [
-        {
+      ensureUsers = [ {
           name = "dendrite";
           ensurePermissions."DATABASE dendrite" = "ALL PRIVILEGES";
-        }
-      ];
-      package = pkgs.postgresql_15;
-      settings = {
-        checkpoint_timeout = "5min";
-        effective_cache_size = "1GB";
-        effective_io_concurrency = 100;
-        maintenance_work_mem = "320MB";
-        max_parallel_maintenance_workers = 4;
-        max_parallel_workers_per_gather = 4;
-        max_wal_senders = 0;
-        random_page_cost = 1.25;
-        shared_buffers = "512MB";
-        wal_buffers = -1;
-        work_mem = "32MB";
-      };
+      } ];
     };
   };