about summary refs log tree commit diff
path: root/matrix.nix
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2022-11-28 16:54:46 +0900
committerNguyễn Gia Phong <mcsinyx@disroot.org>2022-11-28 16:54:46 +0900
commitccb3560f85b698b7d97ec40334f99b1a514aa2cb (patch)
tree5f3aabdc575723cc8e8f041e9aec87ca398b3cbf /matrix.nix
parent3cddfd29bcac6705fd6904844b8ea7649ee5ca2a (diff)
downloadnixos-conf-ccb3560f85b698b7d97ec40334f99b1a514aa2cb.tar.gz
Use nginx directly for Element
New element-web derivation is wrapped and breaks the IPFS hack.
Diffstat (limited to 'matrix.nix')
-rw-r--r--matrix.nix20
1 files changed, 7 insertions, 13 deletions
diff --git a/matrix.nix b/matrix.nix
index 24dc1e9..38b96ed 100644
--- a/matrix.nix
+++ b/matrix.nix
@@ -91,7 +91,13 @@ in {
       "than.${domain}" = {
         enableACME = true;
         forceSSL = true;
-        locations."/".proxyPass = "http://localhost:8080";
+        root = pkgs.element-web.override {
+          conf = {
+            default_server_config = client;
+            default_theme = "dark";
+            room_directory.servers = [ "loang.net" ];
+          };
+        };
       };
     };
 
@@ -107,16 +113,4 @@ in {
       package = pkgs.postgresql_14;
     };
   };
-
-  users.users.root.packages = let
-    element-ipfs = pkgs.callPackage ./element-ipfs.nix {
-      conf = {
-        default_server_config = client;
-        default_theme = "dark";
-        room_directory = {
-          servers = [ "loang.net" ];
-        };
-      };
-    };
-  in [ element-ipfs ];
 }