about summary refs log tree commit diff
path: root/push.nix
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2023-01-02 02:36:25 +0900
committerNguyễn Gia Phong <mcsinyx@disroot.org>2023-01-02 02:52:17 +0900
commitf0bdbb1caff9e072c8f3dea73ff25986c3a05718 (patch)
tree63065072578b204b2c20fd0ea4c24bc8114a565a /push.nix
parent431494d2e7d4dd14a550f06e31a1d0e28c30fef8 (diff)
downloadnixos-conf-f0bdbb1caff9e072c8f3dea73ff25986c3a05718.tar.gz
Serve ntfy
Diffstat (limited to 'push.nix')
-rw-r--r--push.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/push.nix b/push.nix
new file mode 100644
index 0000000..235cbcd
--- /dev/null
+++ b/push.nix
@@ -0,0 +1,37 @@
+# Push notification setup
+# Copyright (C) 2023  Nguyễn Gia Phong
+#
+# This file is part of loang configuration.
+#
+# Loang configuration is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as published
+# by the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# Loang configuration is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public License
+# along with loang configuration.  If not, see <https://www.gnu.org/licenses/>.
+
+{ config, ... }:
+let address = "localhost:21840";
+in {
+  services = {
+    ntfy-sh = {
+      enable = true;
+      settings.listen-http = address;
+    };
+
+    nginx.virtualHosts."tin.${config.networking.domain}" = {
+      enableACME = true;
+      forceSSL = true;
+      locations."/" = {
+        proxyPass = "http://${address}";
+        proxyWebsockets = true;
+      };
+    };
+  };
+}