about summary refs log tree commit diff
path: root/static.nix
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2022-06-27 22:54:45 +0900
committerNguyễn Gia Phong <mcsinyx@disroot.org>2022-06-27 22:54:45 +0900
commit4d7b3a19578c3888f04159c88990106440866383 (patch)
treeecba6bfe3ce6458f956cf6f79d59cda9dc146074 /static.nix
parent266e0aaca33ab96758ebb3ded4dc2cd825b1089e (diff)
downloadnixos-conf-4d7b3a19578c3888f04159c88990106440866383.tar.gz
Give owocean a nginx vhost
Diffstat (limited to 'static.nix')
-rw-r--r--static.nix19
1 files changed, 14 insertions, 5 deletions
diff --git a/static.nix b/static.nix
index f50fb5e..1a44bd6 100644
--- a/static.nix
+++ b/static.nix
@@ -54,15 +54,24 @@ in {
 
     nginx = {
       enable = true;
+      enableReload = true;
       recommendedGzipSettings = true;
       recommendedOptimisation = true;
       recommendedProxySettings = true;
       recommendedTlsSettings = true;
-      virtualHosts.${domain} = {
-        enableACME = true;
-        forceSSL = true;
-        locations."/".index = "index.xhtml";
-        root = "/var/lib/www/${domain}";
+      virtualHosts = {
+        ${domain} = {
+          enableACME = true;
+          forceSSL = true;
+          locations."/".index = "index.xhtml";
+          root = "/var/lib/www/${domain}";
+        };
+
+        "owocean.${domain}" = {
+          enableACME = true;
+          forceSSL = true;
+          root = "/var/lib/www/owocean.${domain}";
+        };
       };
     };
   };