about summary refs log tree commit diff
path: root/static.nix
diff options
context:
space:
mode:
authorNguyễn Gia Phong <cnx@loang.net>2023-07-27 01:44:21 +0900
committerNguyễn Gia Phong <cnx@loang.net>2023-07-27 01:45:25 +0900
commitd36a0b9d3b9ce64283b03469fd4f577c976e3390 (patch)
treebcdd1d3321d6281a102997f0449b1efb2df897ea /static.nix
parentc4938c54ff6156c050411bd42b9ed3aa5c894ee0 (diff)
downloadnixos-conf-d36a0b9d3b9ce64283b03469fd4f577c976e3390.tar.gz
Snapshot OpenNIC stuff
I should get back on the webring impl some time soon.
Diffstat (limited to 'static.nix')
-rw-r--r--static.nix29
1 files changed, 19 insertions, 10 deletions
diff --git a/static.nix b/static.nix
index 6ff96aa..4bf71b4 100644
--- a/static.nix
+++ b/static.nix
@@ -75,16 +75,25 @@ in {
             add_header Strict-Transport-Security "max-age=31536000; includeSubDomains" always;
           '';
           forceSSL = true;
-          locations = {
-            "/".index = "index.html index.xhtml";
-            "/~mingnho/chat" = {
-              proxyPass = "http://127.0.0.1:3000";
-              proxyWebsockets = true;
-            };
-          };
+          http2 = false;
+          locations."/".index = "index.html index.xhtml";
           root = "/var/lib/www/${domain}";
         };
 
+        "khoanh.${domain}" = {
+          enableACME = true;
+          forceSSL = true;
+          locations."/".index = "index.xhtml";
+          root = "/var/lib/www/khoanh.${domain}";
+        };
+
+        "cercle.libre" = {
+          addSSL = true;
+          useACMEHost = "khoanh.${domain}";
+          locations."/".index = "index.xhtml";
+          root = "/var/lib/www/cercle.libre";
+        };
+
         "adol.pw" = {
           enableACME = true;
           forceSSL = true;
@@ -99,6 +108,8 @@ in {
           forceSSL = true;
           root = "/var/lib/www/septagram.suricrasia.online";
         };
+
+        "xrvs.geek".root = "/var/lib/www/xrvs.geek";
       } // (let aliasOpenNIC = openNIC: icann: config: {
         ${openNIC} = {
           # https://wiki.opennic.org/opennic/tls
@@ -110,9 +121,7 @@ in {
           forceSSL = true;
         } // config;
       };
-      in (aliasOpenNIC "cercle.libre" "khoanh.${domain}" {
-        root = "/var/lib/www/cercle.libre";
-      }) // (aliasOpenNIC "sinyx.indy" "cnx.gdn" {
+      in (aliasOpenNIC "sinyx.indy" "cnx.gdn" {
         root = "/var/lib/www/cnx.gdn";
       }) // (aliasOpenNIC "pix.sinyx.indy" "px.cnx.gdn" {
         locations = {