about summary refs log tree commit diff
path: root/ipfs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ipfs.nix')
-rw-r--r--ipfs.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/ipfs.nix b/ipfs.nix
index a2bf6a3..ace7764 100644
--- a/ipfs.nix
+++ b/ipfs.nix
@@ -1,6 +1,11 @@
 { config, pkgs, ... }:
 let domain = config.networking.domain;
 in {
+  networking.firewall = {
+    allowedTCPPorts = [ 4001 ];
+    allowedUDPPorts = [ 4001 ];
+  };
+
   security.acme.certs.${domain} = {
     credentialsFile = pkgs.writeText "namesilo.env" ''
       NAMESILO_API_KEY_FILE=/var/lib/acme/namesilo.key