about summary refs log tree commit diff
path: root/push.nix
diff options
context:
space:
mode:
Diffstat (limited to 'push.nix')
-rw-r--r--push.nix16
1 files changed, 5 insertions, 11 deletions
diff --git a/push.nix b/push.nix
index a6111c0..401f843 100644
--- a/push.nix
+++ b/push.nix
@@ -20,17 +20,6 @@
 let domain = "tin.${config.networking.domain}";
 in {
   services = {
-    ntfy-sh = {
-      enable = true;
-      settings = {
-        base-url = "https://${domain}";
-        # Cannot write to log for some reason,
-        # TODO: Ask on their forum about that
-        # log-level = "info";
-        # log-file = "/var/log/ntfy-sh/ntfy.log";
-      };
-    };
-
     nginx.virtualHosts."${domain}" = {
       enableACME = true;
       forceSSL = true;
@@ -39,5 +28,10 @@ in {
         proxyWebsockets = true;
       };
     };
+
+    ntfy-sh = {
+      enable = true;
+      settings.base-url = "https://${domain}";
+    };
   };
 }