about summary refs log tree commit diff homepage
path: root/pyproject.toml
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2020-03-03 21:24:41 +0700
committerNguyễn Gia Phong <mcsinyx@disroot.org>2020-03-03 21:48:00 +0700
commitb90e6c272c1f76da43992323ffd0f148f759f408 (patch)
tree0cbec0dee9f9c4e234fc6cecbd9d83e885cc4089 /pyproject.toml
parent5e5778d814c3d76cf74aa4e660d5fbaeeeb50c82 (diff)
downloadbrutalmaze-b90e6c272c1f76da43992323ffd0f148f759f408.tar.gz
Switch to flit for build
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml31
1 files changed, 31 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..5be1f72
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,31 @@
+[build-system]
+requires = ['flit_core >=2,<3']
+build-backend = 'flit_core.buildapi'
+
+[tool.flit.metadata]
+module = 'brutalmaze'
+author = 'Nguyễn Gia Phong'
+author-email = 'mcsinyx@disroot.org'
+home-page = 'https://github.com/McSinyx/brutalmaze'
+requires = ['appdirs', 'pygame>=1.9', 'setuptools']
+description-file = 'README.rst'
+classifiers = [
+    'Development Status :: 4 - Beta',
+    'Environment :: MacOS X',
+    'Environment :: Win32 (MS Windows)',
+    'Environment :: X11 Applications',
+    'Intended Audience :: End Users/Desktop',
+    'License :: OSI Approved :: GNU Affero General Public License v3 or later (AGPLv3+)',
+    'Natural Language :: English',
+    'Operating System :: OS Independent',
+    'Programming Language :: Python',
+    'Programming Language :: Python :: 3 :: Only',
+    'Topic :: Games/Entertainment :: Arcade']
+keywords = 'pygame,shmup,maze,ai-challenges'
+license = 'AGPLv3+'
+
+[tool.flit.entrypoints.console_scripts]
+brutalmaze = "brutalmaze.game:main"
+
+[tool.flit.sdist]
+exclude = ['docs', 'wiki']