about summary refs log tree commit diff homepage
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py32
1 files changed, 32 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..d295fe9
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,32 @@
+#!/usr/bin/env python
+# -*- coding: utf-8 -*-
+from setuptools import setup
+
+with open('README.rst') as f:
+    long_description = f.read()
+
+setup(
+    name='brutalmaze',
+    version='0.0.1',
+    description='Brutal Maze',
+    long_description=long_description,
+    url='https://github.com/McSinyx/brutalmaze',
+    author='Nguyễn Gia Phong',
+    author_email='vn.mcsinyx@gmail.com',
+    license='GPLv3+',
+    classifiers=[
+        'Development Status :: 1 - Planning'
+        'Environment :: MacOS X',
+        'Environment :: Win32 (MS Windows)',
+        'Environment :: X11 Applications',
+        'Intended Audience :: End Users/Desktop',
+        'License :: OSI Approved :: GNU General Public License v3 or later (GPLv3+)',
+        'Natural Language :: English',
+        'Operating System :: OS Independent',
+        'Programming Language :: Python',
+        'Topic :: Games/Entertainment :: Role-Playing'],
+    keywords='',
+    packages=['brutalmaze'],
+    install_requires=['pygame>=1.9'],
+    package_data={'brutalmaze': ['*.xm']},
+    entry_points={'gui_scripts': ['brutalmaze = brutalmaze:main']})