about summary refs log tree commit diff homepage
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py31
1 files changed, 0 insertions, 31 deletions
diff --git a/setup.py b/setup.py
deleted file mode 100755
index 4b350f9..0000000
--- a/setup.py
+++ /dev/null
@@ -1,31 +0,0 @@
-#!/usr/bin/env python3
-from setuptools import setup
-
-with open('README.rst') as f:
-    long_description = f.read()
-
-setup(
-    name='brutalmaze',
-    version='0.9.0',
-    description="Minimalist thrilling shoot 'em up game",
-    long_description=long_description,
-    url='https://github.com/McSinyx/brutalmaze',
-    author='Nguyễn Gia Phong',
-    author_email='vn.mcsinyx@gmail.com',
-    license='AGPLv3+',
-    classifiers=[
-        'Development Status :: 4 - Beta',
-        'Environment :: MacOS X',
-        'Environment :: Win32 (MS Windows)',
-        'Environment :: X11 Applications',
-        'Intended Audience :: End Users/Desktop',
-        'License :: OSI Approved :: GNU Affero General Public License v3 or later (AGPLv3+)',
-        'Natural Language :: English',
-        'Operating System :: OS Independent',
-        'Programming Language :: Python',
-        'Topic :: Games/Entertainment :: Arcade'],
-    keywords='pygame shmup arcade-game maze ai-challenges',
-    packages=['brutalmaze'],
-    install_requires=['appdirs', 'pygame>=1.9'],
-    package_data={'brutalmaze': ['icon.png', 'soundfx/*.ogg', 'settings.ini']},
-    entry_points={'console_scripts': ['brutalmaze = brutalmaze.game:main']})