about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
index 8ec7eb8..b8ce9dc 100644
--- a/shell.nix
+++ b/shell.nix
@@ -48,6 +48,12 @@ let
     inherit hash;
     binRenameHook = binRenameHook version;
   };
+  proj = version: commit: hash: callPackage ./proj {
+    inherit version;
+    inherit commit;
+    inherit hash;
+    binRenameHook = binRenameHook version;
+  };
 in mkShell {
   packages = [
     (cppcheck "9261.buggy"
@@ -74,5 +80,11 @@ in mkShell {
     (md4c "107.fixed"
       "5d7c35973e5d06b46ca21b5b6e292c56dba7ca23"
       "sha256-N/vIRhXuU948z0O4NXKMSKOZGAEE6UjGDT5oqrGpUy8=")
+    (proj "1654.buggy"
+      "c45855b38f701a66a96cbd3fe4534f6a52c393b1"
+      "sha256-t+RYX4HRdlNlb8IvFXmjvD8C9P1e5/rCA+dkw1JSNW4=")
+    (proj "1654.fixed"
+      "9b561406e1ddcde02e868bef908e5cd5140745c7"
+      "sha256-zdxidjNOoExFpbqAasKpfs6coLkEVA9U9rvNkQ7XgSI=")
   ];
 }