about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
index 3dd09ef..d94ae88 100644
--- a/shell.nix
+++ b/shell.nix
@@ -5,6 +5,10 @@
 
 with import <nixpkgs> { };
 let
+  grep-2_6 = fetchurl {
+    url = "mirror://gnu/grep/grep-2.6.tar.xz";
+    hash = "sha256-YsNien9DBt1gBAED27fZ8SIOSlTFV9ndDEwy9t1itRE=";
+  };
   grep-2_12 = fetchurl {
     url = "mirror://gnu/grep/grep-2.12.tar.xz";
     hash = "sha256-Tc4KT7g93QEg31HgC1L6dg8u2GddTUwLCuZCumkurWQ=";
@@ -19,6 +23,12 @@ let
   };
 in mkShell {
   packages = [
+    (grep "8f08d8e2.parent" grep-2_6
+      "c1cb19fe67f4c83f9232087ae03c178905d62b0d"
+      "sha256-tT3H9pehJ8X6XPf6qyhUvjKspQZXvCd2I4uQQuabOn8=")
+    (grep "8f08d8e2" grep-2_6
+      "8f08d8e282bf3d4917e94135e67ba17d738313ce"
+      "sha256-xQO/d/nTk/q/7Sq6m+exZX7jwYzqbhcKirw9tqC7+zI=")
     (grep "55cf7b6a.parent" grep-2_12
       "a2e0193455e620f6bad1005500da418d9eba2ae6"
       "sha256-Q1Xye4qHdWOlZSJ+S+T9Cy/71OLN+WE97Va84BFoV/Q=")