about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix16
1 files changed, 14 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index 52541b8..8ec7eb8 100644
--- a/shell.nix
+++ b/shell.nix
@@ -19,7 +19,7 @@ let
     executable = true;
     destination = "/nix-support/setup-hook";
   };
-  cppcheck = version: commit: hash: callPackage ./cppcheck.nix {
+  cppcheck = version: commit: hash: callPackage ./cppcheck {
     inherit version;
     inherit commit;
     inherit hash;
@@ -33,7 +33,7 @@ let
     url = "mirror://gnu/grep/grep-2.12.tar.xz";
     hash = "sha256-Tc4KT7g93QEg31HgC1L6dg8u2GddTUwLCuZCumkurWQ=";
   };
-  grep = version: base: commit: hash: callPackage ./grep.nix {
+  grep = version: base: commit: hash: callPackage ./grep {
     inherit version;
     inherit base;
     snapshot = fetchurl {
@@ -42,6 +42,12 @@ let
     };
     binRenameHook = binRenameHook version;
   };
+  md4c = version: commit: hash: callPackage ./md4c {
+    inherit version;
+    inherit commit;
+    inherit hash;
+    binRenameHook = binRenameHook version;
+  };
 in mkShell {
   packages = [
     (cppcheck "9261.buggy"
@@ -62,5 +68,11 @@ in mkShell {
     (grep "55cf7b6a" grep-2_12
       "55cf7b6a1905320c36702a476b09ebb29a2934d3"
       "sha256-uUHEG4bDDNFiVgj/1mIkttp1B7tlZ1HOWJGPEfbCErU=")
+    (md4c "107.buggy"
+      "e278609ee06ad7f9efcb06da48188a4b837ed11b"
+      "sha256-UoqBSOnlfDsTHz/uLGIUEgmTSiU408iUcwAJTLdbEPM=")
+    (md4c "107.fixed"
+      "5d7c35973e5d06b46ca21b5b6e292c56dba7ca23"
+      "sha256-N/vIRhXuU948z0O4NXKMSKOZGAEE6UjGDT5oqrGpUy8=")
   ];
 }