about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..3dd09ef
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,29 @@
+# Nix shell entry point
+#
+# SPDX-FileCopyrightText: 2023 Nguyễn Gia Phong
+# SPDX-License-Identifier: AGPL-3.0-or-later
+
+with import <nixpkgs> { };
+let
+  grep-2_12 = fetchurl {
+    url = "mirror://gnu/grep/grep-2.12.tar.xz";
+    hash = "sha256-Tc4KT7g93QEg31HgC1L6dg8u2GddTUwLCuZCumkurWQ=";
+  };
+  grep = version: base: commit: hash: callPackage ./grep.nix {
+    inherit version;
+    inherit base;
+    snapshot = fetchurl {
+      url = "http://git.savannah.gnu.org/cgit/grep.git/snapshot/grep-${commit}.tar.gz";
+      inherit hash;
+    };
+  };
+in mkShell {
+  packages = [
+    (grep "55cf7b6a.parent" grep-2_12
+      "a2e0193455e620f6bad1005500da418d9eba2ae6"
+      "sha256-Q1Xye4qHdWOlZSJ+S+T9Cy/71OLN+WE97Va84BFoV/Q=")
+    (grep "55cf7b6a" grep-2_12
+      "55cf7b6a1905320c36702a476b09ebb29a2934d3"
+      "sha256-uUHEG4bDDNFiVgj/1mIkttp1B7tlZ1HOWJGPEfbCErU=")
+  ];
+}