about summary refs log tree commit diff
path: root/nix/awesome.nix
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2021-07-07 22:14:22 +0700
committerNguyễn Gia Phong <mcsinyx@disroot.org>2021-07-07 22:14:22 +0700
commitf140f08bc6c39037958048294fd241a28d8da607 (patch)
treea825016ac64b2a3be8a012011397a1da7f25bb38 /nix/awesome.nix
parent88051c9ccfa9b863b41f0ae86dbb1caaeb739743 (diff)
downloaddotfiles-f140f08bc6c39037958048294fd241a28d8da607.tar.gz
Snapshot config before there're too much
I thought I could always make meaningful config msgs.
Diffstat (limited to 'nix/awesome.nix')
-rw-r--r--nix/awesome.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/nix/awesome.nix b/nix/awesome.nix
new file mode 100644
index 0000000..15c7bd3
--- /dev/null
+++ b/nix/awesome.nix
@@ -0,0 +1,39 @@
+{ pkgs, ... }:
+
+{
+  fonts.fonts = with pkgs; [ julia-mono lmodern ];
+
+  services = {
+    autorandr.enable = true;
+    xserver = {
+      enable = true;
+      desktopManager.xterm.enable = false;
+      displayManager.startx.enable = true;
+      windowManager.awesome.enable = true;
+
+      layout = "us";
+      xkbOptions = "caps:ctrl_modifier,compose:menu";
+      libinput.enable = true; # Enable touchpad support.
+    };
+  };
+
+  i18n = {
+    defaultLocale = "en_US.UTF-8";
+    inputMethod = {
+      enabled = "ibus";
+      ibus.engines = with pkgs.ibus-engines; [ table table-others ];
+    };
+  };
+
+  environment.systemPackages = with pkgs; [
+    gnome.adwaita-icon-theme gnome.networkmanagerapplet qt5ct
+    clipbuzz playerctl pulsemixer xclip xdotool
+    aerc amfora ncdu newsboat ranger ueberzug rxvt-unicode vim_configurable
+    arandr audacious keynav scrot sigil xorg.xkill zathura
+    firefox libreoffice nheko transmission-gtk
+  ];
+
+  programs.nm-applet.enable = true;
+  programs.slock.enable = true;
+  programs.udevil.enable = true;
+}