about summary refs log tree commit diff
path: root/nix/configuration.nix
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2023-06-18 17:26:00 +0900
committerNguyễn Gia Phong <mcsinyx@disroot.org>2023-06-18 17:40:34 +0900
commit550ec84fb625ca75ae3a44e90c162455925463b2 (patch)
treeaa1f8ec81dbbb00662a0ed08f6b7cf4e0cb91b69 /nix/configuration.nix
parentf561b1396d1d5e468e4f28f99937dce31079d0d7 (diff)
downloaddotfiles-550ec84fb625ca75ae3a44e90c162455925463b2.tar.gz
Update NixOS network config
Diffstat (limited to 'nix/configuration.nix')
-rw-r--r--nix/configuration.nix20
1 files changed, 10 insertions, 10 deletions
diff --git a/nix/configuration.nix b/nix/configuration.nix
index eef0813..e77fc68 100644
--- a/nix/configuration.nix
+++ b/nix/configuration.nix
@@ -1,8 +1,4 @@
-# Help is available in the configuration.nix(5) man page
-# and in the NixOS manual (accessible by running 'nixos-help').
-
 { config, pkgs, ... }:
-
 {
   imports = [
     ./hardware-configuration.nix
@@ -33,19 +29,18 @@
         "cnx.gdn" "px.cnx.gdn" "src.cnx.gdn"
       ];
     in {
-      "127.0.0.1" = [ "9gag.com" "voz.vn" ];
       "37.205.11.127" = loang;
       "2a03:3b40:100::1:2" = loang;
     };
     nameservers = [
-      # ns5.ca.us.dns.opennic.glue
-      "137.184.12.79" "2604:a880:4:1d0::4d:e000"
-      # ns4.au.dns.opennic.glue
-      "168.138.8.38" "2603:c023:c002:f4aa:a208:5df4:ee55:b70a"
+      # ns4.any.dns.opennic.glue
+      "134.195.4.2"
+      # ns4.ca.us.dns.opennic.glue
+      "147.182.243.49"
     ];
     networkmanager = {
+      dns = "none";
       enable = true;
-      insertNameservers = config.networking.nameservers;
     };
 
     nftables = {
@@ -138,6 +133,11 @@
   };
 
   environment = {
+    etc."resolv.conf".text = ''
+      nameserver 134.195.4.2
+      nameserver 147.182.243.49
+      options edns0
+    '';
     localBinInPath = true;
     systemPackages = with pkgs; [
       atool compsize cryptsetup htop-vim inotify-tools killall rsync unzip zip