about summary refs log tree commit diff
path: root/nix/configuration.nix
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2020-12-26 15:41:26 +0700
committerNguyễn Gia Phong <mcsinyx@disroot.org>2020-12-26 15:41:26 +0700
commit73ce3f687fc3699a246d6daa4a44c698c0e788dc (patch)
treef597d393423e61bacdb753a63b22dff7e76d984a /nix/configuration.nix
parentbfd59f83b7af16541e8b70c1321470c65131ae29 (diff)
downloaddotfiles-73ce3f687fc3699a246d6daa4a44c698c0e788dc.tar.gz
Update 2020-12-26
Diffstat (limited to 'nix/configuration.nix')
-rw-r--r--nix/configuration.nix128
1 files changed, 0 insertions, 128 deletions
diff --git a/nix/configuration.nix b/nix/configuration.nix
deleted file mode 100644
index e001553..0000000
--- a/nix/configuration.nix
+++ /dev/null
@@ -1,128 +0,0 @@
-# Edit this configuration file to define what should be installed on
-# your system.  Help is available in the configuration.nix(5) man page
-# and in the NixOS manual (accessible by running ‘nixos-help’).
-
-{ config, pkgs, ... }:
-
-{
-  imports =
-    [ # Include the results of the hardware scan.
-      ./hardware-configuration.nix
-    ];
-
-  # Use the systemd-boot EFI boot loader.
-  boot.loader.systemd-boot.enable = true;
-
-  networking.hostName = "nix"; # Define your hostname.
-  # Enables wireless support via wpa_supplicant.
-  # networking.wireless.enable = true;
-
-  # The global useDHCP flag is deprecated,
-  # therefore explicitly set to false here.
-  # Per-interface useDHCP will be mandatory in the future,
-  # so this generated config replicates the default behaviour.
-  networking.useDHCP = false;
-  networking.interfaces.enp1s0.useDHCP = true;
-  networking.interfaces.wlp2s0.useDHCP = true;
-
-  # Configure network proxy if necessary
-  # networking.proxy.default = "http://user:password@proxy:port/";
-  # networking.proxy.noProxy = "127.0.0.1,localhost,internal.domain";
-  
-  # Enable NetworkManager
-  networking.networkmanager.enable = true;
-
-  # Select internationalisation properties.
-  i18n = {
-    defaultLocale = "en_US.UTF-8";
-    inputMethod = {
-      enabled = "ibus";
-      ibus.engines = with pkgs.ibus-engines; [ table table-others
-                                               typing-booster ];
-    };
-  };
-
-  console = {
-    font = "Lat2-Terminus16";
-    keyMap = "us";
-  };
-
-  # Set your time zone.
-  time.timeZone = "Asia/Ho_Chi_Minh";
-
-  # List packages installed in system profile. To search, run:
-  # $ nix search wget
-  environment.systemPackages = with pkgs; with kdeApplications; [
-    ack htop mc stow zip
-    alacritty emacs git nix-prefetch-scripts pkg-config
-    alure2 libogg libsndfile libvorbis openal opusfile
-    aria2 curl firefox ipfs thunderbird w3m wget
-    ark ktorrent libreoffice okular spectacle
-    audaciousQt5 ffmpeg-full mpv zbar
-    azimuth duckmarines freedink gweled liquidwar lugaru tbe xonotic
-    blender frei0r glfw gmic-qt-krita kdenlive krita simplescreenrecorder
-    cmake gcc gdb man-pages posix_man_pages
-    dict dictdDBs.eng2fra dictdDBs.fra2eng dictdDBs.wiktionary dictdDBs.wordnet
-    efibootmgr refind
-    go guile jdk12 lua octave rakudo rlwrap sbcl
-    lmodern texlive.combined.scheme-full
-    (python38.withPackages(ps: with ps; [
-      flake8 pip setuptools tox twine wheel
-      cython numpy moderngl pillow pygame ]))
-  ];
-
-  # Some programs need SUID wrappers, can be configured further or are
-  # started in user sessions.
-  programs.mtr.enable = true;
-  programs.gnupg.agent = { enable = true; enableSSHSupport = true; };
-
-  # List services that you want to enable:
-  services.dictd.enable = true;
-  services.dictd.DBs = with pkgs.dictdDBs; [ eng2fra fra2eng
-                                             wiktionary wordnet ];
-
-  # Emacs daemon
-  services.emacs.enable = false;
-  services.emacs.install = true;
-  services.emacs.defaultEditor = true;
-
-  # Enable the OpenSSH daemon.
-  # services.openssh.enable = true;
-
-  # Open ports in the firewall.
-  # networking.firewall.allowedTCPPorts = [ ... ];
-  # networking.firewall.allowedUDPPorts = [ ... ];
-  # Or disable the firewall altogether.
-  # networking.firewall.enable = false;
-
-  # Enable CUPS to print documents.
-  services.printing.enable = true;
-
-  # Enable sound.
-  sound.enable = true;
-  hardware.pulseaudio.enable = true;
-
-  # Enable the X11 windowing system.
-  services.xserver.enable = true;
-  services.xserver.layout = "us";
-  services.xserver.xkbOptions = "caps:ctrl_modifier,compose:ralt";
-
-  # Enable touchpad support.
-  services.xserver.libinput.enable = true;
-
-  # Enable the KDE Desktop Environment.
-  services.xserver.displayManager.sddm.enable = true;
-  services.xserver.desktopManager.plasma5.enable = true;
-
-  # Define a user account. Don't forget to set a password with ‘passwd’.
-  users.users.cee = {
-    isNormalUser = true;
-    extraGroups = [ "wheel" "networkmanager" ];
-  };
-
-  # This value determines the NixOS release with which your system is to be
-  # compatible, in order to avoid breaking some software such as database
-  # servers. You should change this only after NixOS release notes say you
-  # should.
-  system.stateVersion = "20.03"; # Did you read the comment?
-}