about summary refs log tree commit diff
path: root/nix/configuration.nix
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2021-11-06 20:48:42 +0700
committerNguyễn Gia Phong <mcsinyx@disroot.org>2021-11-06 20:48:42 +0700
commiteee8ffa30773602391cc5264d721e30410e4f2c9 (patch)
treee5e618eebc8b3524cb87d29d7dab1da2c05c51d0 /nix/configuration.nix
parent35fda4e697a6a774065020b551e9c80ab0630ae8 (diff)
downloaddotfiles-eee8ffa30773602391cc5264d721e30410e4f2c9.tar.gz
Prepare for NixOS reinstallation
Diffstat (limited to 'nix/configuration.nix')
-rw-r--r--nix/configuration.nix33
1 files changed, 15 insertions, 18 deletions
diff --git a/nix/configuration.nix b/nix/configuration.nix
index 75fd419..37a0a83 100644
--- a/nix/configuration.nix
+++ b/nix/configuration.nix
@@ -11,15 +11,17 @@
     ./games.nix
   ];
 
-  # Use the systemd-boot EFI boot loader.
-  boot.loader = {
-    efi.canTouchEfiVariables = true;
-    grub = {
-      enable = true;
-      device = "nodev";
-      efiSupport = true;
-      useOSProber = true;
-      splashImage = null;
+  boot = {
+    binfmt.emulatedSystems = [ "aarch64-linux" ];
+    loader = {
+      efi.canTouchEfiVariables = true;
+      grub = {
+        enable = true;
+        device = "nodev";
+        efiSupport = true;
+        useOSProber = true;
+        splashImage = null;
+      };
     };
   };
 
@@ -44,11 +46,6 @@
     # firewall.allowedUDPPorts = [ ... ];
     # Or disable the firewall altogether.
     # firewall.enable = false;
-
-    # Overcoming my strange addiction
-    extraHosts = ''
-      0.0.0.0 9gag.com
-    '';
   };
 
   # Set your time zone.
@@ -62,14 +59,14 @@
 
   users.users.sea = {
     isNormalUser = true;
-    extraGroups = [ "networkmanager" "video" "wheel" ];
+    extraGroups = [ "dialout" "networkmanager" "video" "wheel" ];
   };
 
   nix.autoOptimiseStore = true;
   environment.systemPackages = with pkgs; [
-    htop isync killall oathToolkit rsync stow unzip w3m wget
+    htop inotify-tools isync killall oathToolkit rsync stow tor unzip w3m wget
     mpv pavucontrol sent vimiv-qt yacreader youtube-dl
-    ffmpeg gifski gimp imagemagick inkscape pdftk simplescreenrecorder
+    ffmpeg gifski gimp imagemagick inkscape pdftk simplescreenrecorder sox
   ];
 
   security.rtkit.enable = true;
@@ -93,7 +90,7 @@
     };
 
     dictd = {
-      # enable = true;
+      enable = true;
       DBs = with pkgs.dictdDBs; [ wiktionary wordnet ];
     };
   };