about summary refs log tree commit diff
path: root/nix/devel.nix
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2021-11-06 20:48:42 +0700
committerNguyễn Gia Phong <mcsinyx@disroot.org>2021-11-06 20:48:42 +0700
commiteee8ffa30773602391cc5264d721e30410e4f2c9 (patch)
treee5e618eebc8b3524cb87d29d7dab1da2c05c51d0 /nix/devel.nix
parent35fda4e697a6a774065020b551e9c80ab0630ae8 (diff)
downloaddotfiles-eee8ffa30773602391cc5264d721e30410e4f2c9.tar.gz
Prepare for NixOS reinstallation
Diffstat (limited to 'nix/devel.nix')
-rw-r--r--nix/devel.nix22
1 files changed, 6 insertions, 16 deletions
diff --git a/nix/devel.nix b/nix/devel.nix
index 1de9179..ebd4da7 100644
--- a/nix/devel.nix
+++ b/nix/devel.nix
@@ -2,11 +2,11 @@
 
 {
   environment.systemPackages = with pkgs; [
-    exa fd gitAndTools.gitFull glow jq manpages ripgrep rlwrap
-    clojure gcc guile julia-stable-bin lua python3 rakudo zig
-    bintools gdb gnumake leiningen mypy nix-index pkg-config
-    plantuml texlive.combined.scheme-full
-  ] ++ (with python3Packages; [ flit pip ]);
+    exa fd gitAndTools.gitFull glow jq minicom manpages ripgrep rlwrap
+    gcc julia-stable-bin lua python3 rakudo zig
+    bintools gdb gnumake luaPackages.luacheck mypy pkg-config
+    plantuml sile texlive.combined.scheme-full
+  ] ++ (with python3Packages; [ flit pip tox ]);
 
   programs.mtr.enable = true;
   programs.gnupg.agent = {
@@ -17,18 +17,8 @@
   services = {
     # openssh.enable = true;
     ipfs = {
-      enable = true;
+      enable = false;
       dataDir = "/data/IPFS";
     };
-
-    postgresql = {
-      enable = true;
-      enableTCPIP = true;
-      authentication = pkgs.lib.mkOverride 10 ''
-        local all all trust
-        host all all ::1/128 trust
-        host all all 127.0.0.1/32 password
-      '';
-    };
   };
 }