about summary refs log tree commit diff
path: root/nix/devel.nix
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2021-07-07 22:14:22 +0700
committerNguyễn Gia Phong <mcsinyx@disroot.org>2021-07-07 22:14:22 +0700
commitf140f08bc6c39037958048294fd241a28d8da607 (patch)
treea825016ac64b2a3be8a012011397a1da7f25bb38 /nix/devel.nix
parent88051c9ccfa9b863b41f0ae86dbb1caaeb739743 (diff)
downloaddotfiles-f140f08bc6c39037958048294fd241a28d8da607.tar.gz
Snapshot config before there're too much
I thought I could always make meaningful config msgs.
Diffstat (limited to 'nix/devel.nix')
-rw-r--r--nix/devel.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/nix/devel.nix b/nix/devel.nix
new file mode 100644
index 0000000..113d966
--- /dev/null
+++ b/nix/devel.nix
@@ -0,0 +1,34 @@
+{ pkgs, ... }:
+
+{
+  environment.systemPackages = with pkgs; [
+    exa fd gitAndTools.gitFull glow jq manpages ripgrep rlwrap
+    clojure gcc guile julia-stable-bin lua python3 rakudo zig
+    bintools gdb gnumake leiningen pkg-config python38Packages.pip
+    groff plantuml texlive.combined.scheme-full
+  ];
+
+  programs.mtr.enable = true;
+  programs.gnupg.agent = {
+    enable = true;
+    enableSSHSupport = true;
+  };
+
+  services = {
+    # openssh.enable = true;
+    ipfs = {
+      enable = true;
+      dataDir = "/data/IPFS";
+    };
+
+    postgresql = {
+      enable = true;
+      enableTCPIP = true;
+      authentication = pkgs.lib.mkOverride 10 ''
+        local all all trust
+        host all all ::1/128 trust
+        host all all 127.0.0.1/32 password
+      '';
+    };
+  };
+}