about summary refs log tree commit diff
path: root/nix/devel.nix
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2022-07-04 12:48:10 +0900
committerNguyễn Gia Phong <mcsinyx@disroot.org>2022-07-04 12:48:10 +0900
commitf2181f49b7ce72fb37ef506172987c2cef2a1863 (patch)
tree59f7513fce3431ca386c12161041af47ddf90504 /nix/devel.nix
parent5de43bb3740eef3f040da93eea1fe08c9bc26263 (diff)
downloaddotfiles-f2181f49b7ce72fb37ef506172987c2cef2a1863.tar.gz
Install some good stuff
Diffstat (limited to 'nix/devel.nix')
-rw-r--r--nix/devel.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/nix/devel.nix b/nix/devel.nix
index 1be5435..76e60c5 100644
--- a/nix/devel.nix
+++ b/nix/devel.nix
@@ -1,9 +1,9 @@
-{ pkgs, ... }:
+{ lib, pkgs, ... }:
 
 {
   environment.systemPackages = with pkgs; [
     exa fd gitAndTools.gitFull glow jq minicom man-pages ripgrep rlwrap
-    gcc lua python3 qbe rakudo zig
+    clojure gcc go lua python3 qbe rakudo zig
     bintools gdb gnumake luaPackages.luacheck mypy pkg-config
     plantuml texlive.combined.scheme-full
   ] ++ (with python3Packages; [ flit pip tox ]);
@@ -29,4 +29,6 @@
       localDiscovery = true;
     };
   };
+
+  systemd.services.ipfs.preStart = lib.mkForce "";
 }