about summary refs log tree commit diff
path: root/nix/games.nix
diff options
context:
space:
mode:
authorNguyễn Gia Phong <cnx@loang.net>2024-05-13 02:10:05 +0900
committerNguyễn Gia Phong <cnx@loang.net>2024-05-13 02:10:05 +0900
commit849a7ad18688358489f315d5a8c69e0ae76cbd16 (patch)
tree5b743c2e6ebfd40d4f75c73c088594ac1c19803b /nix/games.nix
parente445f6ad4c4665e83523c85406ccde2084d6d2a7 (diff)
downloaddotfiles-849a7ad18688358489f315d5a8c69e0ae76cbd16.tar.gz
Clean up laptop env
Diffstat (limited to 'nix/games.nix')
-rw-r--r--nix/games.nix28
1 files changed, 15 insertions, 13 deletions
diff --git a/nix/games.nix b/nix/games.nix
index 7b90d75..0189ca7 100644
--- a/nix/games.nix
+++ b/nix/games.nix
@@ -1,17 +1,19 @@
-{ config, pkgs, ... }:
+{ pkgs, ... }:
 {
-  environment.systemPackages = with pkgs; [
-    _20kly hedgewars scorched3d # strategy
-    astromenace chromium-bsu # scrolling
-    taisei # shmup
-    bastet moon-buggy n2048 ttyper # text
+  users.users.sea.packages = with pkgs; [
+    _20kly hedgewars # strategy
+    bastet moon-buggy n2048 # text
     blackshades xonotic-glx # fps
-    blobwars superTux teeworlds # platformer
-    bonzomatic # engine
-    extremetuxracer gl117 gltron superTuxKart # vehicle
-    flare freedroidrpg hyperrogue # slash
-    frozen-bubble pinball xbill # coffeebreak
-    neverball # puzzle
+    superTux # platformer
+    pianobooster # engine
+    extremetuxracer superTuxKart # vehicle
+    flare # slash
+    frozen-bubble neverball pinball xbill # coffeebreak
+    steamPackages.steam-fhsenv-without-steam.run
   ];
-  hardware.opengl.driSupport32Bit = true;
+
+  hardware = {
+    opengl.driSupport32Bit = true;
+    pulseaudio.support32Bit = true;
+  };
 }