about summary refs log tree commit diff
path: root/nix/games.nix
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2021-07-07 22:14:22 +0700
committerNguyễn Gia Phong <mcsinyx@disroot.org>2021-07-07 22:14:22 +0700
commitf140f08bc6c39037958048294fd241a28d8da607 (patch)
treea825016ac64b2a3be8a012011397a1da7f25bb38 /nix/games.nix
parent88051c9ccfa9b863b41f0ae86dbb1caaeb739743 (diff)
downloaddotfiles-f140f08bc6c39037958048294fd241a28d8da607.tar.gz
Snapshot config before there're too much
I thought I could always make meaningful config msgs.
Diffstat (limited to 'nix/games.nix')
-rw-r--r--nix/games.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/nix/games.nix b/nix/games.nix
new file mode 100644
index 0000000..ec0e2d8
--- /dev/null
+++ b/nix/games.nix
@@ -0,0 +1,23 @@
+{ config, pkgs, ... }:
+
+{
+  nixpkgs.config.allowUnfree = true;
+
+  environment.systemPackages = with pkgs; [
+    _20kly hedgewars globulation2 scorched3d teeworlds # strategy
+    astromenace chromium-bsu # scrolling
+    azimuth cdogs-sdl taisei # shmup
+    bastet moon-buggy n2048 # text
+    # blackshades redeclipse warsow xonotic-glx # fps
+    blobwars openclonk sienna superTux # platformer
+    bonzomatic # edu
+    extremetuxracer gl117 gltron superTuxKart # vehicle
+    flare freedroidrpg hyperrogue # slash
+    frozen-bubble gnujump gtetrinet pinball xbill # coffeebreak
+    neverball orthorobot trackballs # puzzle
+    (steam.override {
+      nativeOnly = true;
+      extraPkgs = pkgs: [ SDL2_net ];
+    }).run gnome.gtk # launcher
+  ];
+}