about summary refs log tree commit diff
path: root/nix/hardware-configuration.nix
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2021-07-07 22:14:22 +0700
committerNguyễn Gia Phong <mcsinyx@disroot.org>2021-07-07 22:14:22 +0700
commitf140f08bc6c39037958048294fd241a28d8da607 (patch)
treea825016ac64b2a3be8a012011397a1da7f25bb38 /nix/hardware-configuration.nix
parent88051c9ccfa9b863b41f0ae86dbb1caaeb739743 (diff)
downloaddotfiles-f140f08bc6c39037958048294fd241a28d8da607.tar.gz
Snapshot config before there're too much
I thought I could always make meaningful config msgs.
Diffstat (limited to 'nix/hardware-configuration.nix')
-rw-r--r--nix/hardware-configuration.nix43
1 files changed, 43 insertions, 0 deletions
diff --git a/nix/hardware-configuration.nix b/nix/hardware-configuration.nix
new file mode 100644
index 0000000..9ac7c6c
--- /dev/null
+++ b/nix/hardware-configuration.nix
@@ -0,0 +1,43 @@
+# Do not modify this file!  It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations.  Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+  imports = [ (modulesPath + "/installer/scan/not-detected.nix") ];
+
+  boot.initrd.availableKernelModules = [
+    "xhci_pci" "ahci" "nvme" "usbhid" "usb_storage" "sd_mod" "rtsx_pci_sdmmc"
+  ];
+  boot.initrd.kernelModules = [ ];
+  boot.kernelModules = [ "kvm-intel" ];
+  boot.extraModulePackages = [ ];
+
+  fileSystems = {
+    "/" = {
+      device = "/dev/disk/by-uuid/34058769-4280-4374-ad92-259554380a9e";
+      fsType = "ext4";
+    };
+
+    "/boot" = {
+      device = "/dev/disk/by-uuid/8EB8-6EDD";
+      fsType = "vfat";
+    };
+
+    "/home" = {
+      device = "/dev/disk/by-uuid/69991f9d-8fec-4b32-8e3e-83d6a2c64257";
+      fsType = "ext4";
+    };
+
+    "/data" = {
+      device = "/dev/disk/by-uuid/02594f2b-d681-49fc-8f4a-0616d44c8987";
+      fsType = "ext4";
+    };
+  };
+
+  swapDevices = [
+    { device = "/dev/disk/by-uuid/6f45a147-3b44-4eb9-8ac3-2201e80cff5e"; }
+  ];
+
+  powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
+}