about summary refs log tree commit diff
path: root/nix/awesome.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/awesome.nix')
-rw-r--r--nix/awesome.nix44
1 files changed, 29 insertions, 15 deletions
diff --git a/nix/awesome.nix b/nix/awesome.nix
index 5ef2fe5..20d703e 100644
--- a/nix/awesome.nix
+++ b/nix/awesome.nix
@@ -1,20 +1,28 @@
 { pkgs, ... }:
 {
-  environment.systemPackages = with pkgs; let wee-slack = weechat.override {
+  users.users.sea.packages = with pkgs; let wee-slack = weechat.override {
     configure = { ... }: {
       scripts = [ weechatScripts.wee-slack ];
     };
   };
   in [
-    aerc amfora calcurse dante mu ncdu ranger scrot senpai zathura
+    aerc amfora dante mu scrot senpai ueberzugpp zathura
     arandr audacious kid3 qsynth rxvt-unicode
     clipbuzz keynav playerctl pulsemixer xclip xdotool xorg.xkill
+    gnome.adwaita-icon-theme
     libreoffice liferea nheko tor-browser-bundle-bin wee-slack
-    networkmanagerapplet nextcloud-client transmission-gtk
-    gnome.adwaita-icon-theme qt5ct
+    networkmanagerapplet transmission-gtk
+    python3Packages.argostranslate
   ];
 
-  fonts.packages = with pkgs; [ lmodern noto-fonts-cjk-sans noto-fonts-emoji ];
+  fonts = {
+    fontconfig.defaultFonts = {
+      monospace = [ "Latin Modern Mono" ];
+      sansSerif = [ "Latin Modern Sans" ];
+      serif = [ "Latin Modern Roman" ];
+    };
+    packages = with pkgs; [ lmodern noto-fonts-cjk-sans noto-fonts-emoji ];
+  };
 
   hardware.brillo.enable = true;
 
@@ -81,13 +89,17 @@
     slock.enable = true;
   };
 
-  qt = {
-    enable = true;
-    platformTheme = "qt5ct";
-  };
-
   services = {
     autorandr.enable = true;
+    libinput.enable = true; # touchpad
+
+    pipewire = {
+      enable = true;
+      alsa.enable = true;
+      jack.enable = true;
+      pulse.enable = true;
+    };
+
     xserver = {
       videoDrivers = [ "intel" ];
       deviceSection = ''
@@ -95,13 +107,15 @@
       '';
 
       enable = true;
-      desktopManager.xterm.enable = false;
-      displayManager.startx.enable = true;
+      displayManager.sx.enable = true;
       windowManager.awesome.enable = true;
 
-      layout = "us";
-      xkbOptions = "caps:ctrl_modifier,compose:menu";
-      libinput.enable = true; # Enable touchpad support.
+      xkb = {
+        layout = "us";
+        options = "caps:ctrl_modifier,compose:menu";
+      };
     };
   };
+
+  users.users.sea.extraGroups = [ "video" ]; # for brillo
 }