about summary refs log tree commit diff
path: root/nix/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/configuration.nix')
-rw-r--r--nix/configuration.nix38
1 files changed, 19 insertions, 19 deletions
diff --git a/nix/configuration.nix b/nix/configuration.nix
index cc9d6ef..eef0813 100644
--- a/nix/configuration.nix
+++ b/nix/configuration.nix
@@ -12,7 +12,6 @@
   ];
 
   boot = {
-    binfmt.emulatedSystems = [ "aarch64-linux" ];
     supportedFilesystems = [ "btrfs" ];
     loader = {
       efi.canTouchEfiVariables = true;
@@ -31,7 +30,7 @@
     hosts = let
       loang = [
         "danh.loang.net" "tin.loang.net" "than.loang.net" "xem.loang.net"
-        "cnx.gdn" "cmx.cnx.gdn" "px.cnx.gdn" "src.cnx.gdn"
+        "cnx.gdn" "px.cnx.gdn" "src.cnx.gdn"
       ];
     in {
       "127.0.0.1" = [ "9gag.com" "voz.vn" ];
@@ -138,35 +137,36 @@
     extraGroups = [ "dialout" "ipfs" "networkmanager" "video" "wheel" ];
   };
 
-  environment.systemPackages = with pkgs; [
-    compsize cryptsetup htop-vim inotify-tools killall rsync unzip zip
-    oathToolkit isync stow tor w3m wget yt-dlp
-    imv mpv pavucontrol sent yacreader
-    ffmpeg gimp imagemagick mkvtoolnix mediainfo pdftk simplescreenrecorder sox
-  ];
+  environment = {
+    localBinInPath = true;
+    systemPackages = with pkgs; [
+      atool compsize cryptsetup htop-vim inotify-tools killall rsync unzip zip
+      oathToolkit isync stow tor w3m wget yt-dlp
+      imv mpv pavucontrol sent yacreader
+      ffmpeg mkvtoolnix mediainfo simplescreenrecorder sox
+      # darktable
+      gimp imagemagick pdftk
+    ];
+    wordlist.enable = true;
+  };
 
   programs.iotop.enable = true;
   programs.udevil.enable = true;
 
   security.rtkit.enable = true;
-  # List services that you want to enable:
   services = {
-    pipewire = {
+    dictd = {
       enable = true;
-      alsa.enable = true;
-      pulse.enable = true;
-      # jack.enable = true;
+      DBs = with pkgs.dictdDBs; [ wiktionary wordnet ];
     };
 
-    printing = {
+    pipewire = {
       enable = true;
-      drivers = with pkgs; [ hplip ];
+      alsa.enable = true;
+      pulse.enable = true;
     };
 
-    dictd = {
-      enable = true;
-      DBs = with pkgs.dictdDBs; [ wiktionary wordnet ];
-    };
+    udisks2.enable = true;
   };
 
   # This value determines the NixOS release from which the default