about summary refs log tree commit diff
path: root/nix/devel.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/devel.nix')
-rw-r--r--nix/devel.nix13
1 files changed, 8 insertions, 5 deletions
diff --git a/nix/devel.nix b/nix/devel.nix
index 76e60c5..dacec24 100644
--- a/nix/devel.nix
+++ b/nix/devel.nix
@@ -3,10 +3,10 @@
 {
   environment.systemPackages = with pkgs; [
     exa fd gitAndTools.gitFull glow jq minicom man-pages ripgrep rlwrap
-    clojure gcc go lua python3 qbe rakudo zig
-    bintools gdb gnumake luaPackages.luacheck mypy pkg-config
-    plantuml texlive.combined.scheme-full
-  ] ++ (with python3Packages; [ flit pip tox ]);
+    gcc go guile_3_0 lua python3 rakudo zig
+    bintools gdb gnumake pkg-config
+    texlive.combined.scheme-full
+  ] ++ (with python3Packages; [ flit ]);
 
   programs.mtr.enable = true;
   programs.gnupg.agent = {
@@ -30,5 +30,8 @@
     };
   };
 
-  systemd.services.ipfs.preStart = lib.mkForce "";
+  virtualisation.podman = {
+    dockerCompat = true;
+    enable = true;
+  };
 }