about summary refs log tree commit diff
path: root/nix/devel.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/devel.nix')
-rw-r--r--nix/devel.nix23
1 files changed, 9 insertions, 14 deletions
diff --git a/nix/devel.nix b/nix/devel.nix
index dacec24..8840a1b 100644
--- a/nix/devel.nix
+++ b/nix/devel.nix
@@ -2,32 +2,27 @@
 
 {
   environment.systemPackages = with pkgs; [
-    exa fd gitAndTools.gitFull glow jq minicom man-pages ripgrep rlwrap
-    gcc go guile_3_0 lua python3 rakudo zig
+    bat fd jq ripgrep vim_configurable vimpager-latest
+    exa gitAndTools.gitFull minicom man-pages man-pages-posix rlwrap
+    gcc go guile_3_0 lua rakudo zig
     bintools gdb gnumake pkg-config
     texlive.combined.scheme-full
-  ] ++ (with python3Packages; [ flit ]);
+    (python3.withPackages (pypkgs: with pypkgs; [ flit rsskey ]))
+  ];
 
   programs.mtr.enable = true;
   programs.gnupg.agent = {
     enable = true;
     enableSSHSupport = true;
+    pinentryFlavor = "qt";
   };
 
-  services = {
-    openssh = {
-      enable = true;
+  services.openssh = {
+    enable = true;
+    settings = {
       passwordAuthentication = false;
       kbdInteractiveAuthentication = false;
     };
-
-    ipfs = {
-      enableGC = true;
-      user = "sea";
-      dataDir = "/home/sea/.ipfs";
-      # autoMount = true;
-      localDiscovery = true;
-    };
   };
 
   virtualisation.podman = {