about summary refs log tree commit diff
path: root/nix/etc/nixos/awesome.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/etc/nixos/awesome.nix')
-rw-r--r--nix/etc/nixos/awesome.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/nix/etc/nixos/awesome.nix b/nix/etc/nixos/awesome.nix
new file mode 100644
index 0000000..25e639e
--- /dev/null
+++ b/nix/etc/nixos/awesome.nix
@@ -0,0 +1,39 @@
+{ pkgs, ... }:
+
+{
+  imports = [ ./redshift.nix ];
+
+  fonts.fonts = with pkgs; [ lmodern ];
+
+  services = {
+    autorandr.enable = true;
+    xserver = {
+      enable = true;
+      displayManager.startx.enable = true;
+      windowManager.awesome.enable = true;
+
+      layout = "us";
+      xkbOptions = "caps:ctrl_modifier,compose:menu";
+      libinput.enable = true; # Enable touchpad support.
+    };
+  };
+
+  i18n = {
+    defaultLocale = "en_US.UTF-8";
+    inputMethod = {
+      enabled = "ibus";
+      ibus.engines = with pkgs.ibus-engines; [ table table-others ];
+    };
+  };
+
+  environment.systemPackages = with pkgs; [
+    gnome.adwaita-icon-theme qt5ct
+    gnome.networkmanagerapplet mate.mate-power-manager playerctl pulsemixer
+    rxvt_unicode-with-plugins urxvt_autocomplete_all_the_things urxvt_font_size
+    aerc amfora autocutsel firefox keynav newsboat ranger
+    arandr audacious gimp scrot vim_configurable
+  ];
+
+  programs.nm-applet.enable = true;
+  programs.slock.enable = true;
+}