about summary refs log tree commit diff
path: root/nix/etc/nixos/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/etc/nixos/configuration.nix')
-rw-r--r--nix/etc/nixos/configuration.nix43
1 files changed, 28 insertions, 15 deletions
diff --git a/nix/etc/nixos/configuration.nix b/nix/etc/nixos/configuration.nix
index 7e6e108..2829879 100644
--- a/nix/etc/nixos/configuration.nix
+++ b/nix/etc/nixos/configuration.nix
@@ -13,13 +13,19 @@
 
   # Use the systemd-boot EFI boot loader.
   boot.loader = {
-    systemd-boot.enable = true;
     efi.canTouchEfiVariables = true;
-    grub.useOSProber = true;
+    grub = {
+      enable = true;
+      device = "nodev";
+      efiSupport = true;
+      useOSProber = true;
+      splashImage = null;
+    };
   };
 
   networking = {
     hostName = "nix";
+    nameservers = [ "9.9.9.11" "149.112.112.11" ];
     networkmanager.enable = true;
 
     # The global useDHCP flag is deprecated, therefore explicitly set
@@ -56,23 +62,30 @@
 
   environment.systemPackages = with pkgs; [
     htop isync killall oathToolkit rsync stow w3m wget
-    ffmpeg mpv pavucontrol pqiv
+    ffmpeg mpv pavucontrol vimiv-qt youtube-dl
   ];
 
+  security.rtkit.enable = true;
   # List services that you want to enable:
-  services.printing.enable = true;
+  services = {
+    pipewire = {
+      enable = true;
+      alsa.enable = true;
+      alsa.support32Bit = true;
+      pulse.enable = true;
+      jack.enable = true;
 
-  security.rtkit.enable = true;
-  services.pipewire = {
-    enable = true;
-    alsa.enable = true;
-    alsa.support32Bit = true;
-    pulse.enable = true;
-    jack.enable = true;
-
-    # Use the example session manager (no others are packaged yet so this is
-    # enabled by default, no need to redefine it in your config for now)
-    # media-session.enable = true;
+      # Use the example session manager (no others are packaged yet so this is
+      # enabled by default, no need to redefine it in your config for now)
+      # media-session.enable = true;
+    };
+
+    printing.enable = true;
+
+    dictd = {
+      enable = true;
+      DBs = with pkgs.dictdDBs; [ wiktionary wordnet ];
+    };
   };
 
   # This value determines the NixOS release from which the default