about summary refs log tree commit diff
path: root/nix/etc/nixos/games.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/etc/nixos/games.nix')
-rw-r--r--nix/etc/nixos/games.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/nix/etc/nixos/games.nix b/nix/etc/nixos/games.nix
new file mode 100644
index 0000000..3a48dc4
--- /dev/null
+++ b/nix/etc/nixos/games.nix
@@ -0,0 +1,19 @@
+{ config, pkgs, ... }:
+
+{
+  nixpkgs.config.allowUnfree = true;
+
+  environment.systemPackages = with pkgs; [
+    _20kly hedgewars globulation2 scorched3d teeworlds # strategy
+    astromenace chromium-bsu # scrolling
+    azimuth cdogs-sdl taisei # shmup
+    bastet moon-buggy n2048 # text
+    blackshades redeclipse warsow xonotic-glx # fps
+    blobwars openclonk sienna superTux # platformer
+    bonzomatic # edu
+    extremetuxracer gl117 gltron superTuxKart # vehicle
+    flare freedroidrpg hyperrogue # slash
+    frozen-bubble gnujump gtetrinet pinball xbill # coffeebreak
+    neverball orthorobot trackballs # puzzle
+  ];
+}